Docker version vs apt upgrade


#1

Hi there,

Not a big fan of the change in 2.43.0 of enforcing the preflight checks on updates, as I don’t see an easy way out of the default checks? Scenario is that the docker version is now enforced, but the replicated installer doesn’t pin the version (I’m running on Ubuntu). If you’re enforcing a max version I think you should also make sure a simple apt upgrade doesn’t get you into a situation that’s quite complex to fix.

Any recommendations how to solve this?

Cheers,
Florian


#2

Hi Florian,

We will be upgrading our recommended Docker version to 19.03 in the upcoming release.

Ethan