Upgrade Kubernetes version to latest


#1

We would like to upgrade the Kubernetes version to >=1.15.2. Currently, we are running the replicated version 2.48.0 in our cluster. As per replicated Kubernetes Documentation replicated version >= 2.38.0 is pinned/hardcoded with 1.15.3. Re-running install.sh script with kubernetes-upgrade-patch-version also doesn’t make any difference. Following Official Kubernetes Upgrade documentation also doesn’t help.
It would be a great help if there are ways to upgrade the Kubernetes cluster to the latest stable version(1.19+) or at least 1.18+.


#2

What version of Kubernetes is your cluster on now?


#3

Replicated version - 2.38.0
Kubernetes version - 1.15.3


#4

1.15.3 is the latest version of Kubernetes available with Replicated currently, but 1.15.12 will be available in an upcoming release.


#5

Any ideas on the expected release date?


#6

@areed as per the Announcement in Kubernetes community forum. Kubernetes versions < 1.15.10 / 1.16.x < 1.16.7 / 1.17.x < 1.17.3 are prone to DOS attacks. So we might need to address the issue by upgrading ASAP. An idea on a release date would help us to plan the activities well in advance and to communicate with the customer as well.


#7

Looks like 1.15.12 is available in 2.49.0


#8

Thanks a lot @dmitriy. I hope future releases will target Kubernetes versions 1.16.x < 1.16.7 / 1.17.x < 1.17.3